Back to overview
Downtime

Degraded calendar performance

Nov 01 at 10:53am CET
Affected services
Calendar

Resolved
Nov 01 at 06:24pm CET

We have cleared the backlog of updates from our Public API, this includes updates from dynamic pricing integrations - for example.

We are catching back up on updates from OTAs as part of our calendar sync feature and we catch up on changes we've missed over the next 4 hours.

Reminder that reservation sync, and double booking protection, were not impacted by this issue today.

Updated
Nov 01 at 05:30pm CET

We have made some adjustments to our database and we are seeing load times decrease now, and return back to normal levels.

We still have a large backlog to work through and are continuing to work on ways to get through the backlog as quickly as possible.

Updated
Nov 01 at 01:32pm CET

We have identified the source of the issue and are continuing to work on a solution. The issue is caused by a slow down in our database which is responsible for storing pricing data.

We currently have a backlog of calendar updates from our Public API, as well as a backlog in pulling calendar data from OTAs - we are working our way through the backlog. These delays will be cleared once we fix the underlying issue.

This does not impact reservation sync, and double booking protection.

In the mean time we have deployed a couple of fixes to help ease the load and speed up our direct booking widgets where possible.

Created
Nov 01 at 10:53am CET

We are currently seeing degraded performance involving read operations on our calendar database, which might result in increased load times for the Direct Booking widget and Calendar UI. Our engineers are investigating the issue.